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1. Software requirements





Fractint 19 or higher is required, version 19 has no problem. Cannot guarantee for earlier versions. To view the output animations, you must have a FLI/FLC viewer. I'm looking for a little DOS command-line utility to generate AVI files instead of FLI. Maybe next versions.


If you want to render fractals with Povray 3, you must have Povray 3.0 or higher correctly installed on your computer. That is, FReego should be able to launch Povray from any directory and generate TGA output files from a series of POV files. I used Povray 3.1g. Anyway, you can use FReego without Povray, no problem if you don't use it.


This program was made on a P166 with 32Mb Ram and tested on a 486/33 8 Mb Ram.











2. Install / Uninstall





To install FReego, simply run the DOS installation file FGOSETUP.EXE. You will be asked to specify your Fractint directory (that is, the directory where FRACTINT.EXE is). Once installation is complete, you can remove the installation file FGOSETUP.EXE. An important issue: FReego does not modify any Fractint or system file and does not create any file outside Fractint directory. All the temporary files (except PARs and the batch file, obviously) are stored inside the FREEGO directory. The GIFs in FREEGO\GIF, the FLI/FLC in FREEGO\FLIC, and so on.


The file FREEGO.EXE and the directory FREEGO\ must be in the same directory as FRACTINT.EXE.


To completely remove FReego, manually delete these elements from the Fractint directory: FREEGO.EXE, FREEGO.PAR, FREEGO3D.PAR, FGORUN.BAT, FREEGO\ directory. The removal is complete.





	2.1. File/directory structure





Say, for example, that your Fractint directory is D:\FRACTINT. The following is a list of files and directories required by FReego to run:





d:\fractint\FRACTINT.EXE			Fractint executable


d:\fractint\FREEGO.EXE			FReego executable


d:\fractint\FREEGO\FREEGO.INI		FReego initialization file


d:\fractint\FREEGO\FREEGO.DOC	This document


d:\fractint\FREEGO\RAW2POV.EXE	RAW>POV conversion (see 6.1)


d:\fractint\FREEGO\POVBASE.TXT	'POV' base file


d:\fractint\FREEGO\DTA\			DTA directory


d:\fractint\FREEGO\DTA\DTA.EXE	DTA 2.02 executable


d:\fractint\FREEGO\FLIC\			FLI/FLC output directory


d:\fractint\FREEGO\GIF\			GIF output directory


d:\fractint\FREEGO\POV\			POV output directory


d:\fractint\FREEGO\RAY\			RAY output directory


d:\fractint\FREEGO\SET\			Animations parameters directory


d:\fractint\FREEGO\TEMP\			Temporary directory*


d:\fractint\FREEGO\TGA\			Raytracing images output directory





* The temporary directory is used by FReego only when it reads parameters from a PAR file. FReego deletes all the files in this directory at start-up.











3. FReego general features





FReego can generate 2d/3d animations of fractals using Fractint to generate the single frames. It works like this: you run FReego, then set the Fractint parameters for the 1st and last frames of the animation (see 3.3), then generate a batch file, FGORUN.BAT and 2 parameter files: FREEGO.PAR and FREEGO3D.PAR (for 3d processing). Exit to DOS and run the batch file from the Fractint directory. The GIFs are stored in the FREEGO\GIF\ directory and the final animation in the FREEGO\FLIC\ directory.





The variable parameters are: CtrX / Y / mag / Xmagfactor / rotation / skew, fractal type-specific parameters 1..4, maxiter, color map file (for color map transition) and 3d parameters (see 5)


The fixed parameters: fractal type, video resolution, functions (sin, cos...) 1..4, additional user-defined text.





With FReego, you can generate 3d animations. You have many 3d parameters to handle. You can project a 2d transition on a plane or on a sphere moving/rotating/zooming the plane, move/rotate/zoom a landscape, change colors and move light... you can mix all the parameters to make them change independently... A lot of possible combinations!!





	3.1. Start-up parameters





When it starts, FReego looks for the file FREEGO\FREEGO.INI. This is a text file containing information about:


(1) Available fractal types. I wrote the fractal types available with Fractint 20.0. Some of them will not work on earlier versions.


(2) Available functions


(3) Available video modes (as key combination: F3, SF1...).


You can edit this file. If FReego doesn't find the file, it returns an error message and backs to DOS.


Furthermore, FReego looks for the file FREEGO\SET\DEFAULT.SET and loads the parameter values from there. You can change this file as you want. If FReego can't find the file, uses the program default values (a 2d Mandelbrot zoom). You can load program default values from the 'Edit' > 'Set program default' menu item.





	3.2. Transition SET files





You can save/restore all the parameters for an animation in a SET file. The SET files are stored in and read from the directory FREEGO\SET\. The green list box on the right contains the list of SET files in this directory.


To save an animation, select File > Save parameters or press F12. Then specify the file name without extension.


To load an animation, double click on a file.


A SET file is a plain text file containing a list of variables.





	3.3. Reading parameters from PAR file





You can edit start/end parameters in two ways:


(1) you can start Fractint, find an interesting image, write down the parameters (center-mag, type-specific parameters, function, color map file, etc...), start FReego, type the parameters into their text fields, generate the animation. Or 


(2) you can start Fractint, find the start and end image of your animation, save the parameters with the 'b' command. Save the start image parameters into FREEGO.PAR and give it the name 'start'. Save the end image parameters into FREEGO.PAR and give it the name 'end'.  Then start FReego and select 'Get pars from FREEGO.PAR' from the 'Edit' menu. This command reads FREEGO.PAR, looks for 'start' and 'end' and loads the values from there. Not all the values are read: only type, video, center-mag, parameters, functions, maxiter, color map. All the rest is disregarded. If some of these parameters is not found, it is given a null value ("" or 0).





	3.4. Color map transition





You can specify a 'start color map file' and an 'end color map file'. FReego does not generate intermediate MAP files, but reads the start and end palettes, loads these data in memory, creates a new intermediate  palette for each frame and stores the color string as 'colors=xxx xxx xxx ...' for every frame. I did not implement Pieter Branderhorst's color compression algorithm.





	3.5. Linking animations





FReego cannot generate more than 1 animation at a time. If you want to link together more than 1 animations (for example, a fade in+transition+fade out)


you can:


1) generate the 1st animation GIFs (you can disable flic). Save the parameters (for example, as FADEIN.SET)


2) load FADEIN.SET and swap parameters start/end. All start/end parameters (2d and 3d) values are swapped.


3) set new end parameters and save them (for example, MIDDLE1.SET)


4) generate the 2nd animation GIFs. Before running fgorun.bat, edit the file and delete the command 'del freego\gif\*.gif'. It's the 1st line.


5) load MIDDLE.SET and go on from point 3 (save as MIDDLE2.SET for example)...


You can go on and link as many animations as you want. Enable flic generation only when you generate the last animation.











4. Step by step examples





I think some step-by-step examples are the best way to learn how FReego works. I'll describe the program features along the way. I assume that you have correctly installed FReego (see 2). I'll tell you the values of the parameters to set up to have a functional and fast to generate result. Obviously you can change these parameters as you like. The samples are already included in the zip distribution file.





	4.1. A Mandelbrot zoom





(1) Start FReego


(2) set the following parameters:


	Ctr-X start	-0.5


	Ctr-X end	-1.186495515


	Ctr-Y start	0


	Ctr-Y end	0.303307331


	Mag start	0.6666666666666666


	Mag end	192.407633


	Rotat		empty


	skew		empty


	Param1..4	empty


	Maxiter	empty


	Map start	choose BLUES.MAP


	Map end	choose VOLCANO.MAP


	Frames	50


	Skip last	unchecked


	Fractal	mandel


	Video		F3


	Functions	empty


(3) select Edit > 3D processing. Leave 'Enable 3d processing' unchecked. Press 'Ok'.


(4) select Edit > Animation settings. Set the following parameters:


	File name	SAMPLE41


	Ping pong	unchecked


	Insert 1...	unchecked


	Dithering	No dither


Press 'Ok'.


(5) select File > Save (or press F12). Type a name for the transition set (8 characters without extension), for example 'SAMPLE41'. Press 'Ok'. The name should appear in the green list on the right.


(6) select Make > Full screen (or press F5)


(7) FReego asks you if you want to view the output files (FREEGO.PAR, FREEGO3D.PAR, FGORUN.BAT). Select yes or no.


(8) select File > Quit (or press ctrl+X)


(9) At the DOS prompt, run FGORUN.BAT


(10) Wait until finished


(time on a P166: 1'15")


(11) That's done. If everything went right, you should find the file SAMPLE41.FLI in the directory FREEGO\FLIC\.





Now, let's make another animation. It's the same Mandelbrot zoom we have just done, but projected on a 3d plane.


Do the following:





(1) Start FReego


(2) Load the previous parameters by double-clicking on 'SAMPLE41' in the list on the right


(3) change the following parameters:


	Map start	GOODEGA.MAP


	Map end	VOLCANO.MAP	


(3) select Edit > Animation settings. Set file name as 'SAMP413D'. Press 'Ok'.


(4) select Edit > 3D processing. Press 'Default'.


(5) Enable 3d processing.


(6) change the following parameters:


	Roughness start	10


	Roughness end	10


Press 'Ok'


(7) select File > Save. Type a new name, for example 'SAMP413D'. Press 'Ok'.


(8) Follow the steps 6-10 of the previous sample


(time on a P166: 2'53")





	4.2. A Julia 2d morph





(1) Start FReego


(2) set the following parameters:


	Ctr-X start	0


	Ctr-X end	0


	Ctr-Y start	0


	Ctr-Y end	0


	Mag start	0.6666666666666666


	Mag end	0.6666666666666666


	Rotat		empty


	skew		empty


	Param1 start	0


	Param1 end	0.3


	Param2 start	0


	Param2 end	0.6


	Param3..4	empty


	Maxiter	empty


	Map start	choose GOODEGA.MAP


	Map end	choose GOODEGA.MAP


	Frames	50


	Skip last	unchecked


	Fractal	julia


	Video		F3


	Functions	empty


(3) select Edit > 3D processing. Leave 'Enable 3d processing' unchecked. Press 'Ok'.


(4) select Edit > Animation settings. Set the following parameters:


	File name	SAMPLE42


	Ping pong	unchecked


	Insert 1...	unchecked


	Dithering	No dither


Press 'Ok'.


(5) select File > Save (or press F12). Type a name for the transition set (8 characters without extension), for example 'SAMPLE42'. Press 'Ok'. The name should appear in the green list on the right.


(6) Follow the steps 6-10 of the sample 4.1


(time on a P166: 0'57")





	4.3. A Landscape 3d morph





Now, let's do something different. We'll generate a landscape that 'grows up'. We start with a green plane that becomes a sort of iceberg (looks like that, more or less)... do the following:





(1) Start FReego


(2) set the following parameters:


	Ctr-X start	unchanged


	Ctr-X end	unchanged


	Ctr-Y start	unchanged


	Ctr-Y end	unchanged


	Mag start	unchanged


	Mag end	unchanged


			(we're working with a plasma, Fractint will not care about 			Ctr-X, Ctr-Y, mag and other options)


	Rotat		unchanged


	skew		unchanged


	Param1 start	4


	Param1 end	4


	Param3..4	empty


	Maxiter	unchanged


	Map start	choose GREEN.MAP


	Map end	choose BLUES.MAP


	Frames	50


	Skip last	unchecked


	Fractal	plasma


	Video		F3


	Functions	empty


(3) select Edit > 3d processing. Press 'Default'.


(4) Enable 3d processing.


(5) set the following parameters:


	Roughness start	0


	Roughness end	40


	Rotation Y start	60


	Rotation Y end	-60


	Apply to		Only the 1st frame


	3D fill type		light source (after)


Press 'Ok'.


(6) select Edit > Animation settings. Set the following parameters:


	File name	SAMPLE43


	Ping pong	unchecked


	Insert 1...	unchecked


	Dithering	No dither


Press 'Ok'.


(7) select File > Save (or press F12). Type a name for the transition set (8 characters without extension), for example 'SAMPLE43'. Press 'Ok'. The name should appear in the green list on the right.


(8) Follow the steps 6-10 of the sample 4.1


(time on a P166: 8'40")





	4.4. A Mandelbrot 3d morph (a growing spiral)





50 frames for this animation are too few. When it's done, look at it frame by frame and try to imagine the result with 400 frames...





(1) Start FReego


(2) set the following parameters:


	Ctr-X start	-0.13944119035583725


	Ctr-X end	-0.13944119035583725


	Ctr-Y start	0.6496649016565763


	Ctr-Y end	0.6496649016565763


	Mag start	106744.377


	Mag end	106744.377


	Rotat		empty


	skew		empty


	Param1..4	empty


	Maxiter start	10


	Maxiter end	1000


	Map start	choose VOLCANO.MAP


	Map end	choose BLUES.MAP


	Frames	50


	Skip last	unchecked


	Fractal	mandel


	Video		F3


	Functions	empty


(3) select Edit > 3d processing. Press 'Default'.


(4) Enable 3d processing.


(5) set the following parameters:


	Roughness start	5


	Roughness end	5


Press 'Ok'.


(6) select Edit > Animation settings. Set the following parameters:


	File name	SAMPLE44


	Ping pong	unchecked


	Insert 1...	unchecked


	Dithering	No dither


Press 'Ok'.


(7) select File > Save (or press F12). Type a name for the transition set (8 characters without extension), for example 'SAMPLE44'. Press 'Ok'. The name should appear in the green list on the right.


(8) Follow the steps 6-10 of the sample 4.1


(time on a P166: 5'38")











5. 3d processing





Now for 3d processing: when you enable 3d processing, you can vary these parameters through the animation: ScaleX/Y, roughness (ScaleZ), perspective, rotationX/Y/Z. If you enable spherical projection, you can also vary: longitude start/stop, latitude start/stop, radius (note: when spherical projection is enabled, rotation X/Y/Z will not be considered).


You can choose how you want Fractint to generate 3d images: if you select one of the 'light source' options, you can define and vary light parameters through the animation: light vector X/Y/Z, ambient, smoothing factor (fixed).


Then, you can select one of three 3d modes: you can apply 3d transition to (1) every single 2d GIF image that Fractint generates, (2) only the 1st frame, or (3) any other GIF file you select, that will be treated by Fractint as a plasma.


The 1st mode is useful to generate a 3d projection of a 2d animation (for example, a Mandelbrot zoom projected on a plane). The 2nd mode is useful for example when you work with plasma. Since Fractint generates plasma in a random way any time, you can't generate a 3d landscape morphing in the 1st mode. But you can generate a single 2d image and apply 3d on that single image. With the 3rd mode, you can apply the 3d transition to any GIF file (a photo for example); you can rotate or move it in 3d.











6. Povray 3.0 interfacing





Now for PovRay 3 output. Fractint output is raw, contains only informations about the shape of the object, not lights or position of the camera. When you make a 3d transition with Povray output enabled, the batch file FGORUN.BAT will:


(1) generate the 2d GIF series in the FREEGO\GIF\ directory as FGnnnnnn.GIF ;


(2) convert these images in 3d as F3nnnnnn.GIF applying the 3d transition parameters you defined (important: only the 3d shape parameters will be passed to Povray, not rotation, light, zooming! These are used only by Fractint-generated 3d images! You can vary them anyway, see 'RAW2POV conversion utility')


(3) while generating 3d images, it will generate a series of FRACTnnn.RAY files in the Fractint directory (I'm looking for a way to specify a different output directory for these files);


(4) move FRACTnnn.RAY in the directory FREEGO\RAY\;


(5) convert these files in POV 3.0 format using the conversion utility I made FReegoRAW2POV (see below) and store them in the FREEGO\POV\ directory;


(6) render these files and put the output in the FREEGO\TGA\ directory;


(7) build the final animation in the FREEGO\FLIC\ directory.


It's quite a complex way, anyway I tried to make it completely automatic.





	6.1. RAW2POV conversion utility (version 0.1)





This utility is necessary for Povray 3 conversion. What does this utility do? It converts a series of RAY files in a series of functional POV files. There are some things to say about this process:


(1) The RAY files must be Fractint-generated raytrace output files in RAW format.


(2) You should not have to use RAW2POV, since FReego uses it when you enable Povray output from inside FReego. That is, you shouldn't have to care about the conversion process. It is automatic.


(3) When you enable Povray output, FReego asks you to specify a POV base text file. Why? Fractint output, as I said, is raw. You may want to create a scene with lights, camera, other objects, what you want... a Pov scene. FReego uses this trick: I wrote a standard simple Pov file. If you want to see it, it's the file POVBASE.TXT. Somewhere in this file there is a non-Povray command: %InsertFreegoFractalHere%. This is a RAW2POV command. So, once Fractint has generated all the images and FRACTnnn.RAY, RAW2POV takes the file FRACT001.RAY from the directory FREEGO\RAY\, converts its content in POV 3.0 format, reads POVBASE.TXT, puts the resulting fractal shape in the place of %InsertFreegoFractalHere%, save the resulting POV file in the directory FREEGO\POV\, then the same with FRACT002.RAY, and so on... Then the batch file renders these file in sequence (that's why you must have Povray correctly installed) and links them in the final animation, in the FREEGO\FLIC\ directory. This is how the program works. I repeat, you don't have to learn this to use FReego, this is all automatic (or will be in a final version...!). Obviously, if you are expert Povray users, you can use any other base file: just put the string %InsertFreegoFractalHere% where you want the fractal to be and change the base file name in FReego's Povray output settings. Ok? Good.





Now, I said before that you can vary Pov parameters anyway. If you are interested in this, look at POVBASE.TXT. There are other RAW2POV commands which you can insert in a POV base file: you have 100 (0-99) variables to use. You define a start and an end value for the variables you need using the commands %setfreegovarNNstartvalue%, %setfreegovarNNendvalue%, %setfreegovarNNdecimals% (NN=00-99, use 2 digits!), then you put the variables where you want in the file as %freegovarNN%. When RAW2POV converts the file, it knows how many frames the final animation is made of (it is equal to the number of FRACTnnn.RAY in the directory FREEGO\RAY\), calculates the values for all the defined variables for every frame, then substitutes these values during the conversion. Every POV file will be different from the preceding one for (1) the shape of the fractal (if you changed it) and (2) the variables you defined (if you defined them).





IMPORTANT: RAW2POV utility is intended to be used by FReego. If you want to use it alone, you can, but you do it at your own risk. Anyway, this program is independent, it doesn't need any other FReego file to work (except for the base POV file, obviously), so you can copy it elsewhere and use it alone if you need. The correct command-line syntax is:


RAW2POV [BaseFileName] [RAW files directory] [POV output directory]


where:


[BaseFileName] is the name of the base POV text file including RAW2POV commands


[RAW files directory] is the directory containing the input files (notes: input files must be original Fractint-generated raytrace output files in RAW format; RAW2POV can convert at least 2 files, only 1 file returns an error; the directory name must end with "\")


[POV output directory] is the directory where final POV files are stored as FRACTnnn.POV (note: the directory name must end with "\").











7. Revision history





	7.1. Version 0.1beta1 (Aug 2, 2000)





	Adopted DTA 2.02 instead of 1.8


	Improved the calculation algorithm


	Added user-specified additional text for PAR files


	Color map transition


	Added RAW2POV conversion utility


	Functions and video modes added to FREEGO\FREEGO.INI	





	7.2. Version 0.1beta2 (Aug 7, 2000)





	Implemented Povray output batch conversion	


	Fixed TAB order in main screen





	7.3. Version 0.1beta3 (Aug 10, 2000)





	Lots of bugs fixed in Povray output


	Added coarseness to Povray output settings


	Fixed a bug in video resolution save/restore from SET file


	'reset=2000' instead of 'reset' in PAR files


	Check for FRACTINT.EXE


	The FLI/FLC output can be disabled (if you want GIFs only)


	'View output files' uses EDIT DOS command now


	Added GET parameters from FREEGO.PAR


	Added XmagFactor


	Added '10 frames, 320x200' preview





	7.4. Version 0.1 (Aug 13, 2000)





	General program revision


	A lot of tests and bug fixing work!





	7.5. Version 0.11 (Aug 18, 2000)





	Command buttons in the main screen


	Added type-specific fractal parameters 5-6


	Added extra parameters (bailout, bailoutest,reset, float, passes, rseed, 		aspectdrift, formulafile, formulaname, lfile, lname, ifsfile, ifs, 		inside, outside)


	Improved interfacing with Fractint (read pars from FREEGO.PAR)











Warranty disclaimer





This program is licensed free of charge and can be freely distributed provided (1) this doc file is distributed with it, (2) there are no charges other than those necessary for administrative purposes.


Tha author disclaims any and all warranties, whether expressed, implied or statuary, including any implied warranties or merchantibility or of fitness for a particular purpose. In no event shall the author be liable for any incidental or consequential damages of any kind whatsoever arising from the use of this program.
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